Jump to content

Welcome to WatercoolingUK Community Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

Compression Fittings won't Screw into Components?

- - - - - water cooling compression fittings water blocks screw in fittings

  • Please log in to reply
1 reply to this topic

#1
Mario Vale

Mario Vale

    Newbie

  • Members
  • 1 posts
Hi everyone,
 
I'm water cooling for the first time and I'm worried about having a leak, so before even completing the loop and filling it up with water I need some help with figuring out if these fittings are connected properly and if not, how do I tighten them?
 
Here is a link to an album with some pictures http://imgur.com/a/XZQ9b
 
The first image is an EK Water Blocks EK-ACF Fitting 13/19mm - Black screwed into a EVGA GeForce GTX 780 Dual Classified HydroCopper.  It is probably quite hard to tell from this photo, but this is the best I could do for now.  Is there meant to be a gap at the top, between the fitting and the card?
 
The second image with the green O-ring is a Bitspower G1/4 Matte Black Dual Rotary 45-Degree Compression Fitting-ID 1/2" OD 3/4" also into the GTX 780.  Should the O-ring be inside the graphics card slightly?
 
The third image is a compression fitting Bitspower Connection 1/4 Inch to 19 / 13mm - Carbon Black screwed into a Black Ice Nemesis GTX 360mm Radiator.  You can see that the O-ring is flush against the radiator, but the whole fitting isn't flush against the O-ring.
 
The fourth and fifth images are both connections of the Bitspower 1/4 Inch Adjustable Aquapipe II (22-31mm), I think this is the one that looks the most secure to me.
 
What I want to know is, do these look right and, if not, how do I screw the fittings properly into the components as I'm having a hard time screwing them in further?
 
Does anyone have any tips for screwing something into a rotary fitting, as obviously it will keep rotating unless it is clamped down?  I don't really want to clamp them with pliers as I fear I will be crushing the fitting.
 
Thanks.


#2
Aaron

Aaron

    There's ALWAYS room for a quad rad!

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,078 posts

Some of them do look a bit suspect.

 

Do the fittings not have a recess to fit a spanner into? I'm sure some of my old ones did....

 

Been a while since i've done a build but iirc they are usually quite tight to get fully on.

 

Sounds silly, but have you tried taking them off and re-seating the connector??



Project 'S'

Cosmos S - i7 920 DO @ 4Ghz - Gigabyte EX58-UD5
GTX 275 - 6Gb OCZ Gold 1600Mhz
PA120.4 - XSPC DDCBAYTWO - HF Nickel - EK FB



I love chicken chargrills






Also tagged with one or more of these keywords: water cooling, compression fittings, water blocks, screw in, fittings

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users