Jump to content

Welcome to WatercoolingUK Community Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account
Photo

Anyone used one of these before please?

- - - - -

  • Please log in to reply
4 replies to this topic

#1
Martin

Martin

    Newbie

  • Members
  • 3 posts
Hi has anyone used one of these before I got it a while ago from watercooling uk but can not see them on thier sales site anymore.

Posted Image


What im wondering is are they safe and ok to use basicly and how do you power it I know it has molex connector on it but it has x2 and x2 3pin connectors next to the molex ones.

Regards
Martin
Fortress FT01 (soon to be ATCS 840 powdercoated black inside), Q6600 @ 3ghz, Maximus Formula X38, 8gb Geil Blackdragons, True 120 Black, GTX 280, Samsung F3 1TB, Corsair HX1000w, Win 7 64bit

#2
dazza

dazza

    Oh Hai!

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,082 posts
I have used one for about a year now
I just use one molex



#3
Martin

Martin

    Newbie

  • Members
  • 3 posts
Thanks dazza so powering is fine on just the 1 molex then to just be clear m8?
Fortress FT01 (soon to be ATCS 840 powdercoated black inside), Q6600 @ 3ghz, Maximus Formula X38, 8gb Geil Blackdragons, True 120 Black, GTX 280, Samsung F3 1TB, Corsair HX1000w, Win 7 64bit

#4
dazza

dazza

    Oh Hai!

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,082 posts
Think it just depends what your running mate I didnt really look at it tbh I just use one molex but I'm only using I think
3 of the 5v but it made it Easier for cable mangement,
But I used to run a pump and a load of fans off it with no issues.



#5
Martin

Martin

    Newbie

  • Members
  • 3 posts
Thansk again dazza put my mind at rest Interestingly heard back from one place in europe that sells them now and they are saying you need to use both a molex and a 3pin to power it. As you are a user im more than happy to use it now thanks to you cheers again m8 :)
Fortress FT01 (soon to be ATCS 840 powdercoated black inside), Q6600 @ 3ghz, Maximus Formula X38, 8gb Geil Blackdragons, True 120 Black, GTX 280, Samsung F3 1TB, Corsair HX1000w, Win 7 64bit




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users